Notice

This old forum is now only available for consultation/read. User accounts on this old website are blocked.
Please create a new account on seblod.com and use the new forum http://www.seblod.com/community/forums.
Apologies for this perturbation and thank you for your understanding!
Welcome, Guest
Username Password: Remember me

Need help on index_jseblod000.php
(1 viewing) (1) Guest
  • Page:
  • 1

TOPIC: Need help on index_jseblod000.php

Need help on index_jseblod000.php 2 years, 11 months ago #1

  • in2sky
  • ( User )
  • OFFLINE
  • Fresh Boarder
  • Posts: 4
I notice that when using custom template, jseblod is trying to create "index_jseblod000.php" files in template folder then delete them later. But this action increase the server load and my hosting wanna kick me because of this.

I tried to modify the file "plugins/content/cckjseblod.php" which i removed the "index_jseblod000.php" creation and deletion section. Then tried to modify to let it call from the actual file e.g. index.php/index2.php. But don't know why this work only on the first item. The rest is missing from the website. Any suggestion? Anyway to avoid creating "index_jseblod000.php"?

Here's some code that i modified in "plugins/content/cckjseblod.php"

 
if ( $doRm == 1 && JFile::exists( JPATH_SITE.DS.'templates'.DS.$template.DS.'index2.php' ) ) {
$file = 'index2';
$fileToCopy = JPATH_SITE.DS.'templates'.DS.$template.DS.'index2.php';
$fileToRender = JPATH_SITE.DS.'templates'.DS.$template.DS.'index2.php';
} else {
$file = 'index';
$fileToCopy = JPATH_SITE.DS.'templates'.DS.$template.DS.'index.php';
$fileToRender = JPATH_SITE.DS.'templates'.DS.$template.DS.'index.php';
}
// $fileToRender = JPATH_SITE.DS.'templates'.DS.$template.DS.$file.'.php';
// if ( JFile::exists( $fileToCopy ) ) {
// JFile::copy( $fileToCopy, $fileToRender );
// }
 


 
// if ( JFile::exists( $fileToRender ) ) {
// JFile::delete( $fileToRender );
// }
 


My site is hxxp://horpakkhonkaen.com/
The orange banner suppose to have 15 more banner. But with the modification above, only that one displayed.
Last Edit: 2 years, 11 months ago by in2sky.

Re: Need help on index_jseblod000.php 2 years, 11 months ago #2

  • arsalan
  • ( User )
  • OFFLINE
  • Senior Boarder
  • Life is a Game, Play it well and fair. Leave Result on God "Allah"
  • Posts: 41
have you checked cleaning the cache.
Best Regards,
Arsalan Khan

Re: Need help on index_jseblod000.php 2 years, 11 months ago #3

  • in2sky
  • ( User )
  • OFFLINE
  • Fresh Boarder
  • Posts: 4
I cleaned the joomla cache. But the result still the same.

It seems jseblod doesn't use cache at all as it generate index_jseblod000.php everytime someone open the page.

Re: Need help on index_jseblod000.php 2 years, 10 months ago #4

Im actually having thesame issues here...

Re: Need help on index_jseblod000.php 2 years, 10 months ago #5

Hi in2sky & howtowrite101

From 1.8x, if your are using a custom template please make sure that your code didn't have some error, in that case, an index_jseblod000.php file could be created.

Best Regards
If you use SEBLOD CCK, please post a rating and a review at the Joomla! Extensions Directory. Thanks to you.!!"
SEBLOD Vimeo Channel: vimeo.com/channels/seblod
SHAPE YOUR SITE YOUR WAY
  • Page:
  • 1
Time to create page: 0.27 seconds