WeStandWithUkraine

98 Posts
Edwin
9 years ago
Topic

Hello

My registration site form currently has 36 fields. I need to add two more, but it won't allow me. When I click save the field simply returns to the list on the right.

Not sure what the issue is.

Any help would be highly appreciated.

Get a Book for SEBLOD
215 Posts
cubist
9 years ago
1
Level 1

When going over 40+ fields some servers require you to add or edit your php.ini file with the following line:

;set max input
max_input_vars=2500

You might try 1000 first and see if that fixes the problem.

Also make sure you are using php5.3+. Some servers require you to load it in your HTACCESS file, e.g.

# Use PHP 5.3
AddType application/x-httpd-php53 .php

38 Posts
amitomj
8 years ago
0
Level 2


Hi

I`m new with joomla. I tried do chenge the php.ini file but i didn`t find the line «max_input_var».

Can you help me?

Thanks

60 Posts
fredee
9 years ago
0
Level 1

hi

depending on if using linux and the suhosin extension you will have to change suhosin php.ini variables as well if have suhosin installed

cheers

75 Posts
lloyd
9 years ago
0
Level 1

I had the same problem.  Set the max input to max_input_var=3000 in the php.ini file and restart the server and problem solved.

98 Posts
Edwin
9 years ago
5
Level 1

Hi guys

I changed max_input_var = 3000 and it worked.

Thank you everyone for all your help

38 Posts
amitomj
8 years ago
4
Level 2

Hi Edwin

I`m new with joomla. I tried do chenge the php.ini file but i didn`t find the line «max_input_var».

Can you help me?

Thanks

98 Posts
Edwin
8 years ago
3
Level 3

Hello amitomj

That line is in php.ini file. It is <max_input_vars>. Exactly written like this. I am using php 5.4.7.

I hope it helps

38 Posts
amitomj
8 years ago
2
Level 4

Thanks a lot

I think the problem is that i use php 5.3.13. E need to update php.


595 Posts
Octopoos - Mehdi
8 years ago
1
Level 5

Hi amitomj,

Please indicate us if you have solved your problem.

Regards,
Mehdi.

38 Posts
amitomj
8 years ago
0
Level 6

Hi Mehdi

I didn`t solv the problem.

I chenge the «max_input_vars» but i still can`t put more than 40 fields.

When I click save the field returns to the list on the right.

Help!!!

8 years ago
0
Level 1

Hi all,

the problem could come from the PHP configuration, but often it's that the database has some limitation.
You must optimise it by setting the good storage format.
By default, SEBLOD store in VARCHAR(255). So if it's just for an integer, it's better to use INT(x). You must do that for all your fields in the form.


Best regards.

Lionel


1 Post
krupers
7 years ago
0
Level 1

I do not have access to php.ini but i'm added in .htaccess file: 

php_value max_input_vars 3000 
php_value suhosin.get.max_vars 3000 
php_value suhosin.post.max_vars 3000 
php_value suhosin.request.max_vars 3000

for me it's working.

Best regards
krupers

Get a Book for SEBLOD