7 months ago
4
Topic

I have following error in Joomla 4 with Seblod 4

An error has occurred.

0 Call to undefined method CCKController::setError()
Call stack
# Function Location
1 () JROOT/administrator/components/com_cck/controller.php:311
2 CCKController->display() JROOT/libraries/src/MVC/Controller/BaseController.php:678
3 Joomla\CMS\MVC\Controller\BaseController->execute() JROOT/administrator/components/com_cck/cck.php:34
4 require_once() JROOT/libraries/src/Dispatcher/LegacyComponentDispatcher.php:71
5 Joomla\CMS\Dispatcher\LegacyComponentDispatcher::Joomla\CMS\Dispatcher\{closure}() JROOT/libraries/src/Dispatcher/LegacyComponentDispatcher.php:73
6 Joomla\CMS\Dispatcher\LegacyComponentDispatcher->dispatch() JROOT/libraries/src/Component/ComponentHelper.php:361
7 Joomla\CMS\Component\ComponentHelper::renderComponent() JROOT/libraries/src/Application/AdministratorApplication.php:143
8 Joomla\CMS\Application\AdministratorApplication->dispatch() JROOT/libraries/src/Application/AdministratorApplication.php:186
9 Joomla\CMS\Application\AdministratorApplication->doExecute() JROOT/libraries/src/Application/CMSApplication.php:293
10 Joomla\CMS\Application\CMSApplication->execute() JROOT/administrator/includes/app.php:61
11 require_once() JROOT/administrator/index.php:32

Get a Book for SEBLOD
55 Posts
Olek T.
6 months ago
1
Level 1

Since this error looks pretty much like the one descibed by yours truly here, and since noone from Octopoos seem to care, maybe try my workaround. It's bizarre, but if it worked in my case...

6 months ago
0
Level 2

Thank you Olek, that solution worked perfect!

4 months ago
1
Level 1

Hi Elisa,

You still have the problem on a J4/S4 fresh install?

If yes, it's when you switch from one tab to another in a content type form ?

Thx

4 months ago
0
Level 2

Hi Olivier, I fixed the error like described by Olek. The error was on an upgraded site. I wont be able to reproduce ist since it was also just this one  content type. thanks!

Get a VIP membership