This site uses cookies and similar technologies.

If you don't change browser settings, you agree to it.

I understand
93 Posts
nycxav
1 year ago
3
Topic

Hi, 

Here is what I'm trying to achieve: be able to upload large files (1GB) in zip format containing software trial versions (.exe for Windows and .bin for Linux).

I'm using the latest Joomla 3.8.10 and Seblod 3.16 with  php 7.1.6 (on MAMP)

Each and every of these criteria (size, archive, archive content) is potentially a problem apparently. 

Originally when saving the content type with a large file I was sent back to the Seblod home page. I changed the post_max_size and upload_max_filesize values in my php.ini and now I get "successfully saved" however the file is not saved on the server. 

I tried to upload the same file in Media Manager directly and I get an error "You have tried to upload file(s) that are not safe."

I tried with other zip files containing only jpeg files and some of them can be uploaded, some fail with the same error. 

I tried to chnage the configuration of Media Manager Restrict Upload to No, allow more file types to no avail. 

I'm not sure what to do and if there is even a solution.

I would like to avoid installing another extension. i'm doing an upgrade from 2.5 to 3.8. The goal was to move everything to Seblod and not have to install additional extensions.

Help greatly appreciated. 

X

Get a Book for SEBLOD
4229 Posts
Kadministrator
1 year ago
2
Level 1

For sure you are hitting some system limitations, php, apache, mod_security etc, this limitations are set on various levels e.g. for php https://www.sitepoint.com/upload-large-files-in-php/

93 Posts
nycxav
1 year ago
1
Level 2

Thank you Klas for the quick reply.

To narrow down the issue I tried the "hack" posted by pulsarinformatique in this post and it worked. So my conclusion for now is that there may be a way to configure Joomla. Seblod and the Field itself to make it work, provided that the patch mentioned in the post has been included in the latest versions of Seblod. 

I have tried many configuration options, so far without luck (if you have pointers I'm interested) but I'm now confident that I won't have to install additional extensions to handle the upload. Obviously my need is for administrator only so I am less concerned about what will be uploaded in this form than I would be if it were a user populated form. 

Regards.
X

110 Posts
deralex
10 days ago
0
Level 3

Hello Xav,

I've got similar problems. Did you find a solution?

Regards

Alex

Get a VIP membership