19 Posts
LPO PACA
11 months ago
4
Topic

Hi,

With Joomla 4.3.3 and Seblod 4.0.6, I have this error when validating my form : 1364 Field 'my_column_mysl' doesn't have a default value

The "site_content" table is well filled, but the Seblod "site_cck_store_xxx" table remains empty, not even a line created.

On Joomla 3 this form works very well with same web host. 

Thanks for your help !

Get a Book for SEBLOD
19 Posts
LPO PACA
11 months ago
0
Level 1

You have to go to the Seblod settings, general tab, choose "Legacy (Joomla 3)" for SQL Mode.

26 Posts
MicroChief
11 months ago
1
Level 1

Question. New Project. This table creation only option? Enable SqlMode - Joomla3, will I do e.g. content type and switch back? Should I set this option permanently?

19 Posts
LPO PACA
11 months ago
0
Level 2

This option seems useful to me only for sites created on Joomla 3 and migrated to Joomla 4

26 Posts
MicroChief
11 months ago
0
Level 1

I tested in all ways, the table is not automatically created. I'm having difficulty creating separate independent content content. Maybe some plugin?

Get a VIP membership