This site uses cookies and similar technologies.

If you don't change browser settings, you agree to it.

I understand
71 Posts
Filip
3 months ago
Topic

I have browsed some of the materials concerning options for the content view but have not been able to decipher a solution with my newbie skills... So apologies in advance if this question has been addressed elsewhere already. 

My problem is essentially that when I move from the list of articles into content view in the frontend, the content is displayed under the default "home" setting.

The issue I have with this is that several modules that have been linked to my "home" page is then displayed when i dont want them too...

Could anyone tell me whether it is possible to assign a menu item to the content view for a specific list?

Thanks in advance!

Get a Book for SEBLOD
2680 Posts
Klasadministrator
3 months ago
1
Level 1

When you set a link on the field in the list you can choose target menu

71 Posts
Filip
3 months ago
0
Level 2

Thanks Klas,

This was easy enough and I found where to assign the menu to the link!

It does however not seem to have solved the problem... the same modules are still displayed even though a menu is assigned. 

Would you have any ideas what the problem could be?

Thanks in advance.

2680 Posts
Klasadministrator
3 months ago
1
Level 1

If newly set menu target is used then appropriate modules should be shown as modules depend on the menu. If you turn off SEF to see nonsef URL's you should be able to see which Itemid is used for the link.

71 Posts
Filip
3 months ago
0
Level 2

It does not direct to the correct itemid for some reason. 

I have assigned a menu item (410) but it still sends the user to the deafult menu item (101).

http://policydatabase.boku.ac.at/images/Screen7.png

2680 Posts
Klasadministrator
3 months ago
1
Level 1

Did you try this:

If you turn off SEF to see nonsef URL's you should be able to see which Itemid is used for the link.

71 Posts
Filip
3 months ago
0
Level 2

This is what i did... assigned itemid 410 (which is my publication list menu item) but it still sends the user to the default menu itemid, which is 101.

2680 Posts
Klasadministrator
3 months ago
2
Level 1

Which itemid is in the link created in the list? If it is not the one set in list->fields->link try cleaning any caches you might have.

If this does not help I would need access to your site to help you further. You can email it to klas.berlic at octopoos.com

71 Posts
Filip
3 months ago
1
Level 2

Thanks Klas,

Clearing the cache doesnt seem to have solved the problem. Sending you an email. 

2680 Posts
Klasadministrator
3 months ago
0
Level 3

Just a notice for others : solved, SEF option in Seblod was set to Native.

Get a VIP membership