WeStandWithUkraine

17 Posts
AlexRag
9 years ago
30
Topic

Hello,

I upgraded to the latest Seblod 3.13 and the issue I was getting with 2.x is still persistent.  All the "Editor" link (next to the word description)

is returning this error:

Not Acceptable

An appropriate representation of the requested resource /administrator/index.php could not be found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

I have JCE Editor intalled.  Is this a configuration problem?

Hoping help is nearby.

Thanks!

Get a Book for SEBLOD
9 years ago
4
Level 1

Hello AlexRag,

Please expose in details the update process. What is the SEBLOD version that you want to upgrade? On which Joomla? Which PHP version?

Regards.

17 Posts
AlexRag
9 years ago
3
Level 2

H Bes,

I upgraded form the last 2.x version to your current version. 

Running Joomla 2.511, PHP 5.38

Thanks!

Alex

9 years ago
2
Level 3

Thank you Alex.

If you upgrade from the version 2.3.9 it works normally well.

It seems that the upgrade has been not executed completely. 

Again download the last version and install it on Joomla installer.

If you have the same error, try the Joomla alternative method, upload the zip file on the "tmp" directory by FTP and select it on Joomla installer.

Regards.

17 Posts
AlexRag
9 years ago
1
Level 4

I have upgraded as recommended but the error continues to appear. 

9 years ago
0
Level 5

Hi,

Please delete your browser cache.

Have you updated JCE too? Add more details about how you use the editor, in a field in your content type? Many editor field in the same content type? Which field?

Regards.

17 Posts
AlexRag
9 years ago
0
Level 1

Essentially everywhere there is an editor link I get this error.  I have a even picked "no editor" in the user setting yielding the same result.    I can send you a screen capture image to show you - let me know how i can send it over.

17 Posts
AlexRag
9 years ago
8
Level 1

Any ideas why this is happening?  I have installed Seblod on several other sites all yielding the same error.   :(

17 Posts
AlexRag
8 years ago
7
Level 2
I'm back again hoping to use Seblod for a couple of sites.  I am currently running the extension in a demo site (Joomla 3.2.3).   This issue continues to haunt me and I cannot figure out why.   Please help.  I see the tremendous potential with this extension, but cannot have complete confidence with this issue lingering.  

I have JCE Editor installed as well.   Hopefully its just some kind of configuration  issue


686 Posts
rpoy
8 years ago
6
Level 3
Hi Alex,

Are all of your sites on the same server?  This sounds like an environment setting.  Check with your host and have a look at the Mod_security setting as discussed here.  Do you have any other extensions installed like SEF/SEO? If so, try disabling them. 

Let us know,

thanks,

Randy

17 Posts
AlexRag
8 years ago
5
Level 4
Hi Randy,

Yes, they are on the same server.   If it is indeed an issue with Mod_security is their something in Seblod's code that's causing it to kick in?  According to the link it mentioned turning off Mod_security but at the same time suggests it turning it off completely is not advisable.   If there are certain rules that can be relaxed  that might be the way to go. - But how can i figure out which rules to turn off?

Thanks,
Alex
686 Posts
rpoy
8 years ago
4
Level 5
Hi Alex,

Have you checked your host to see if there are any FAQs / recommend settings?  Based on my research, the same issue is posted on the JCE, Joomla, and other forums so I don't believe that SEBLOD is causing the issue. 

Have you tried creating a backup with something like Akeeba, and then installing on your local server? 

The only other thing that people were mentioning was SEF/SEO.

regards,

Randy


17 Posts
AlexRag
8 years ago
3
Level 6
I will check with my host, but in the meantime I uninstalled JCE and any other remnants of it like CodeMirror.  I've set TinyMCE as the default editor. 
Strangely, the editor loaded without issue (including, before I uninstalled, JCE) everywhere else on this site except with Seblod. 

My other searches mentioned issues with Joomla 2.5, which does not apply here.   My other research yielded unresolved discussions both Joomla  and JCE.

I also have no SEO extensions installed.

For some reason Seblod is having difficulty pulling in any editor.  Not even the "Description" button loads.   I will contact my host to inquire about  Mod_Security, but I'm really curious to know why Seblod is the only extension I have that can't pull in the editor.    Strange.
686 Posts
rpoy
8 years ago
2
Level 7
Hi Alex,

I have to agree, it is strange.  Can you give the details on your content type?  If you create a content type, and just add a title and WYSIWYG editor do you still get the error?


Please keep me posted.

thanks,

Randy
17 Posts
AlexRag
8 years ago
1
Level 8
Hi Randy,

I am working with the Joomla article Content Type.  I added a couple of field items (calendar and text), but even before I did any modifications the error pre-existed.

I created a blank content type and still see the same issue.     Matter of fact, everywhere there is the description link (new folders, ertc) the modal popup give me the same error.

Thanks,
Alex

4229 Posts
Kadministrator
8 years ago
0
Level 9
Hi,


this really looks like mod_security or similar protection system error, you will need to contact your hosting provider about it to make exceptions to their rules.

What you can do yourself to verify this is to download the site to your computer and try to run it on a local server, if it works there it is definitely a hosting issue. In any case local site development is always recommended as finding errors is much easier that way, also local system can be run without this security systems in the development phase of the site.
332 Posts
Kenneth
8 years ago
3
Level 1
I'm experiencing the same troubles. 

Any of you other use Admin Tools from Akeeba? I'm looking into if this might be the problem for me.

EDIT:
I disabled Admin Tools and removed the .htaccess file created by it, but this dosn't fix the problem for me.
4229 Posts
Kadministrator
8 years ago
2
Level 2
Check if your hosting uses mod_security or suhoshin protection systems
332 Posts
Kenneth
8 years ago
1
Level 3
It uses mod_security. Is that not ok?
4229 Posts
Kadministrator
8 years ago
0
Level 4
Hi,

you will need to ask them to search for problem in their mod_security logs and make exceptions to their rules so they are not triggered. One way to deal with mode security is to protect administration with httpasword that secures it from outside access and then disable mod_security compaltely for administration.
17 Posts
AlexRag
8 years ago
10
Level 1
I have contacted my web host provider as recommended, but there not appear to any errors reports in the mod_security logs.
686 Posts
rpoy
8 years ago
9
Level 2
Hi Alex,

In your Security settings in the cPanel on your site, do you have Password Protect Directories enabled? Have you tired different browsers/ computers from different locations? Have you been able to test this on a local setup to see if you get the same results?

thanks,

Randy
17 Posts
AlexRag
8 years ago
8
Level 3
With the exception of testing locally, I have tried as you suggest.    Is it possible to find out what the links I'd ndicated above are supposed to provide?   Whatever its trying get access to is being blocked somehow.  this might help me pinpoint what is being blocked.
134 Posts
pretobrazza
8 years ago
7
Level 4
Hello Alex,

I'm just throwing in my 5 cents. Have a look at the bottom of THIS TREAD 

Kind regards,
Bernard 
17 Posts
AlexRag
8 years ago
6
Level 5
Hi Bernard,

Interesting.  I'll have a look.   I do think it is related to the editor on the site.

The description & editor link is ... /administrator/index.php?option=com_cck&task=box.add&tmpl=component&file=plugins/cck_field/wysiwyg_editor/tmpl/form.php&id=description&name=description¶ms=100%||280||  

This is where I'm seeing the 404 ERROR noted at the top of this thread.

Thanks,
Alex


134 Posts
pretobrazza
8 years ago
5
Level 6
Have a look at the table #__cck_core_fields in your msql for the rows Article Introtext and Article Fulltext. There, you click on the cell of the column OPIONS2 - 

There if you might see something like:

{"editor":"Jckeditor","width":"100%","height":"280","import":"1"}

Change "Jckeditor" to "jce" in Article Introtext and Article Fulltext and plop ... your problem should be solved in this case. 

I hope this is the problem otherwise I remain without answers too ..

Bernard
17 Posts
AlexRag
8 years ago
4
Level 7
Hi Bernard,

I checked the table and found the intro text to be what you recommend howver the Article Fulltext had : {"editor":"","width":"100%","height":"280","import":"2"}

I changed it to {"editor":"jce","width":"100%","height":"280","import":"1"} but it did not solve the problem.   :(

Oh well,  it was a nice effort.
134 Posts
pretobrazza
8 years ago
3
Level 8
That's a pity I wish this was your problem . Was jce activated when you tried it? 
17 Posts
AlexRag
8 years ago
2
Level 9
It was.  In fact I had completely removed it and just had Joomla's version.  I even made no Editor the default.    This is rather frustrating.  The only thing left to try is test the site locally to rule out the mod_security tip.
134 Posts
pretobrazza
8 years ago
1
Level 10
Hi Alex,

I  just want to make sure because your answer above is not 100% clear as in 1 2 3:

So you first did re-install JCE, enabled it in joomla as being you editor and only then try out the adjustment you made to those 2 rows in the msql table as above?

If indeed you did, and you didn't succeed, please don't forget to reinstate the original settings in your msql to those you mentionned above.,Otherwise problems might accumulate themselves one on top of the other one (fixes)   

Kind regards,
Bernard
17 Posts
AlexRag
8 years ago
0
Level 11
Hi Bernard,

The uninstall, reinstall of JCE and trials with other editors were all before the modifications you had suggested.     The issue I see though is more than just Intro and FullText fields.  I'm seeing it wherever I have the description link as well.    

Thanks,
Alex

Get a VIP membership