This site uses cookies and similar technologies.

If you don't change browser settings, you agree to it.

I understand
61 Posts
Wolfgang Claus
23 days ago
2
Topic

Hi,

some days ago, I created a content type "message" (based on article)  which uploads a pdf-Files in the frontend form. This worked just fine. Then I created a new content type "storeage", by copying the "message" content type using the batch tool of seblod. This worked fine once or twice. But suddenly I get an error message, when saving contents either by messager or by storage. The message is: error 1062. Duplicate entry '0' for key primary. The content nevertheless does exist, but not only once but twice. The first is ok, the second is without created-date, without author and without language. 

I dont remember exactly: maybe I created this content type "storage" first, then deleted it, and later created again.

Does anyone has a idea what to do? 

Do I have to rebuild this content types? Is there a problem with copying content types by using the batch feature?

Thank you

Wolfgang

Get a VIP membership
1222 Posts
Bucklash
23 days ago
1
Level 1

maybe try deleting versions from seblods versions table... i think that helped me in a situation like this... also, make sure all database tables have correct info ie cck_core etc

61 Posts
Wolfgang Claus
23 days ago
0
Level 2

Thank you bucklash,

The forms arent that complex, and I am still in the developement state. So I rebuilt the 2 content types and they work fine.

I did not delete the defekt ones, so that I can check them later.

Wolfgang

Get a VIP membership