17 Posts
KlingstedtBros
7 years ago
23
Topic

Hello.  I designed my system last year with Seblod 2.x and everything was working well.  I upgraded to 3.x this year.  After the upgrade my list-searches stopped working.  I later discovered it was because the submit field type was set to "button" instead of "input".  After changing this, the list-search worked.  Now I've discovered that my submitting form is not working.  I followed the same step and changed the submit button to "input".  Now instead of doing nothing, the form just refreshes when I click submit.  No redirect, no message, nothing.  When I checked the articles, nothing was saved.

The form can be seen here:
http://www.historicbyway.com/list-your-sale-seblod

Storage is set to Custom > Article > [Field Name].  Last year when this app was working, it would save the data for each entry into a seperate article.  In this case, they are ad listings, like a classified.

Any help would be greatly appreciated!


SOLUTION:  There was an unidentified issue with the template.  Upon changed the template to a default one, it worked.

Get a VIP membership
75 Posts
lloyd
7 years ago
14
Level 1

Almost sounds like you have your submit button set to a link. Try creating just a regular button with default settings.

17 Posts
KlingstedtBros
7 years ago
13
Level 2

I swapped the submit button for the default one.  Same behavior.  Submitting just refreshed the page, and clears the form.  No article saved in the back end.

137 Posts
dniezby
7 years ago
1
Level 3

This does sound strange.  How are you verifying that it's not saving your data?  Are you looking at the table you created? Also, if you're not using "Exclusive" fields they will be saved in a different table than the one created by your form.

17 Posts
KlingstedtBros
7 years ago
0
Level 4

It should not be saving the data to a table.  It should be saving the data to an article.  Storage is set to "Custom > Article > introtext" on the custom fields.  The "Name Your Sale" field is set to save as the article title "Standard > Article > title".

The Format looks like this when viewed with the standard Joomla editor:

::cck::143::/cck::
::al_name::Huge Multi-Family Yard Sale!::/al_name::
::al_contact::sstemen@globusfamily.com::/al_contact::
::al_address::13609 Lincoln Highway::/al_address::
::al_loactionnotes::Just east of Van Wert beside the Marsh Foundation::/al_loactionnotes::
::al_days::Friday, Saturday::/al_days::
::al_items::Whirlpool Tub - heated, works great, standard size; Household goods; Table Linens; Decorative Items; Tools; Furniture; Ink Jet Printer - very nice with extra attachments; Laser printer; Clothing - all sizes including name-brand ladies' plus sizes - some never worn; Rugs; Blankets; Christmas tree decorations - very nice, some custom-made; Kitchen items; Building supplies; much more!::/al_items::
::al_image::images/AL2012/212/Yard Sale.jpg::/al_image::


::cck::143::/cck::


75 Posts
lloyd
7 years ago
10
Level 3

Believe dniezby is correct here. Sounds like you were using unexclusive fields. Check the database. Should be Exclusive fields --> storage = standard article and leave last field blank

17 Posts
KlingstedtBros
7 years ago
9
Level 4

Original Storage Settings (per field) (worked last year):

  • AL_Name, AL Contact, AL_Address, AL_Location-Notes, AL_Days, AL_Items, AL_Image:  Custom > Article > introtext (This saves the information in the body of the article)
  • AL_Title: Standard > Article > title (This saves this field as the article title)
  • AL_Community: Standard > Article > db_al_community (I have no idea why this is set this way)
  • AL_Category:  Standard > Article > catid (This automatically puts the articles in a desired Joomla category)
  • AL_Switch: Standard > Article > state (This is to enable and disable the article from the admin form)

There is a checkbox maked "Alter" next to storage.  This is unchecked on all fields.  I have no idea what it does.

I have changed the storage on all the fields set "Custom > Article > introtext" to "Standard > Article > (blank)".  I believe the fields are exclusive, but I'm not sure how to check.  All the fields are saved in the App folder, and the form itself shows the padlock locked.  Unfortunately, I still get the exact same result from the form.


75 Posts
lloyd
7 years ago
8
Level 5

You will have to recreate the fields I think. Exclusive/Unexclusive is set at field creation. Please see my video. It shows the difference and what it all means. That is annoying that it once worked and no longer does though. Video

17 Posts
KlingstedtBros
7 years ago
7
Level 6

Great video series!  I'm bummed you only have two up so far. 

If you have the time to look at my current setup, I've created a user "temphelp" with the password "temphelp".  This will allow you to log in and check everything.  I'm desperate to get this going today.  If you give me your email, I can toss a donation your way as well.

Admin Area

75 Posts
lloyd
7 years ago
6
Level 7

I'm taking a look at as we speak. I re-created your form and tried to use my newly created one and had the same result as yours. So I will continue to look at some other issues and will have an answer here in the next 1/2 hour. Donation not required of course but I won't turn it down :) kylebertsch@gmail.com 

17 Posts
KlingstedtBros
7 years ago
5
Level 8

I saw in your video you set the folder as App Root.  I noticed my folder was not set that way so I changed it.  Then I realized I should not be changing things while your looking, lol.  I did notice you were able to get it to create an article called "Test", so you must be doing something right.  What setting determines how a form redirects after it is submitted correctly?


Again, thanks for the help.

75 Posts
lloyd
7 years ago
0
Level 9

Yes, I was able to submit through the backend but not the front which makes me think it's a permission issue although the settings look fine. Yea sometimes you don't want to make it a root just depends on what you're doing. Redirect can be changed within your content type and click on site form then click on the configuration tab. It's the first option on the right to configure redirect after submission.

75 Posts
lloyd
7 years ago
3
Level 9

I noticed something weird. On the seblod default page in the upper right hand corner there should be an option for both preferences and option and I'm only seeing preferences. Is this the same for you or do both appear? Might be because I'm an admin not a super. Anyways you want to goto options and check your "registered" permissions. or can be done through joomla global configuration. Permissions can also be set within the specific content types but I did not seem to have any results doing that.

17 Posts
KlingstedtBros
7 years ago
2
Level 10

Yes, I have both.  My guess is that it's because I'm a SuperUser and your an Administrator.  I upgraded your account.  You may have to relog.  Also, I set the redirect options, but they don't work, I'm guessing because the form is not successfully submitting. 


I'm wondering if there is an error message being displayed, but the template isn't showing it...


IT'S SOMETHING IN THE TEMPLATE!  I changed the template for the submission page and it worked from the front end.

75 Posts
lloyd
7 years ago
1
Level 11

Yep it was a permission issue or did you fix it with template lol? Either way everything works now! 

17 Posts
KlingstedtBros
7 years ago
0
Level 12

Thanks for your help.  I'm still trying to determine what specifically was wrong with the template to cause the problem.  I'll post it here if I figure it out.  My boss will be back next week.  Once I get his authorization, I'll toss you the donation.  I wont forget.  Thanks!

137 Posts
dniezby
7 years ago
0
Level 1

wow, this topic moved fast.  LOL. lloyd, you did it so fast I didn't even get a chance to try. LOL. 
Well, I'm glad you figured it out. 

One thing I can say about Seblod is that YOU MUST STAY ORGANIZED. If you start creating fields, forms or categories you can easily lose track of where things are.

The other thing you need to realize is that EVERYTHING you create is added or removed from your Joomla backend database. If you use Exclusive fields, you will create a new db table and the fields you create will be added to that form name.  If you're NOT using exclusive fields, then they will be stored in one of the other cck_ tables.

17 Posts
KlingstedtBros
7 years ago
0
Level 1

I've run into a new related problem. 

I've created a new thread here (http://www.seblod.com/community/forums/fields-plug-ins/storage-settings-changed), but pasted it below as well.

Due to changing the storage on all the fields from "Custom > Article > introtext" to "Standard > Article > (blank)", all the previously input articles no longer display properly.  I changed all the settings back, however they still do not recognize the fields that were changed, then changed back.  The information is still saved in the body of the articles, but can no longer be accessed by the forms or displayed in the searches.  The body of the articles, when viewed in Joomla's default editor look like this:


::cck::143::/cck::
::al_name::Huge Multi-Family Yard Sale!::/al_name::
::al_contact::sstemen@globusfamily.com::/al_contact::
::al_address::13609 Lincoln Highway::/al_address::
::al_loactionnotes::Just east of Van Wert beside the Marsh Foundation::/al_loactionnotes::
::al_days::Friday, Saturday::/al_days::
::al_items::Whirlpool Tub - heated, works great, standard size; Household goods; Table Linens; Decorative Items; Tools; Furniture; Ink Jet Printer - very nice with extra attachments; Laser printer; Clothing - all sizes including name-brand ladies' plus sizes - some never worn; Rugs; Blankets; Christmas tree decorations - very nice, some custom-made; Kitchen items; Building supplies; much more!::/al_items::
::al_image::images/AL2012/212/Yard Sale.jpg::/al_image::


When viewed in the Seblod editor, the fields are blank.


Any help would be appreciated.

113 Posts
jimenaes
7 years ago
1
Level 1

Hi

I'm having the same problem, cant create new articles from my front end forms. They do work fine in the backend, and all my forntend permission are ok.

Maybe you could help me.

What do you mean you solve the problem by changing the template to a default one?Do you mean the Seblod site form template or the joomla template? I'm using the default seblod one template for my site form and a the YooMaster template for my site.

Thanks

17 Posts
KlingstedtBros
7 years ago
0
Level 2

My problem was the Joomla template.  I never descovered what exactly the problem was, but I solved the issue by using a default joomla template on the form pages.

27 Posts
abram
7 years ago
0
Level 1

Hi guys,

I've the same problem!! I can create New Articles and Categories from the Backend but can't from Frontend. No one have some ideas? I can't use Joomla default Template on the form page. 

572 Posts
_jrmo
7 years ago
1
Level 1
Did anyone ever figure this out? I also have the same problem.
52 Posts
melihtas
7 years ago
0
Level 2
Hi _jrmo

I experienced this problem once, I tried every option in the button settings, nothing worked. I created a new submit button and deleted the old one and worked like a charm.
572 Posts
_jrmo
7 years ago
0
Level 1
SOLVED
Changing the button didn't work for me.

My issue was cause by a jquery clash. Any page that has a seblod element on it (a form, module, whatever) will load jquery. If your template has another version of jquery loaded it will cause issues. The fix? Remove jquery from your template.

If you need your template to load jquery on certain pages (ones that don't have seblod elements), create a blank "custom HTML" module and assign it to a unique module position and set it to appear only on the pages you want it to. Then in your template replace where you load jquery with this:

<?php if ($this->countModules( 'user1' )) : ?>

<script type="text/javascript" src="/js/jquery.min.js"></script>

<?php endif; ?>

Replace "user1" with whatever your module position is, and make sure you set that src="/..." to wherever your jquery script is on your server.

Cheers,
James
Get a VIP membership