WeStandWithUkraine

18 Posts
cassirer
6 months ago
Topic

Dear All,

I hope that someone of you can help me. I already ask for help in the german seblod forum, they also tried a lot but could not find a solution: https://seblod.time4mambo.de/app-folder-app-verzeichnis/840-button-submit-save-close.html?start=0

I'm using J! 3.10.3 and seblod 3.21.4 with php 7.3.31 and a protostar and have a database of historical persons connected with historical sources. I am not a coder, I'm interested in but work as historians. So please don't judge stupid questions or lack of knowledge too hard.
The hole system was working fine for a year, but since one of the latest updates (I don't know if j! or seblod) in the frontend whenever I press either the "save&close" button or the "save" button, the editing windows are closed and nothing is saved to the database anymore. When I do the same in the backend everything is fine (using the seblod buttons - or the j! buttons).
Checking the firefox console I don't have any error. Just the "zoom" warning and the JQmigrate log.

Has someone please a hint for me, how to solve this problem?

Thanks a lot in advance, greetings from Vienna, Benjamin

Get a VIP membership
43 Posts
Casper
6 months ago
5
Level 1

I upgraded Seblod from 3.20.2 to 3.21.4 yesterday and I have the same problem. Changes are not saved when editing content from the frontend. Content changes are saved normally in the backend.

18 Posts
cassirer
6 months ago
4
Level 2

Hi there,  just an update from my side:

I installed a totally naked j! 3.10.3 and seblod 3.21.4 (i tried as well with 3.21.3 - no changes), just with protostar. I saw that it was not working at all with php8, so I've downgraded to 7.4.2

Then I manually reinstalled my Seblod-Apps and manually added in my php _content, _categories, _user and _usergroups and _cck_core. Then all the cck_store_forms I need and still I have the same problem:

whenever I press the "save" or the "save&close" Button, the editor is closed, nothing is saved.

Please help, thanks in advance, best Benjamin

47 Posts
KKAAZZOO
6 months ago
3
Level 3

How do you open the material for editing? Preferably show in screenshots

18 Posts
cassirer
6 months ago
2
Level 4

Hi KKAAZZOO, just using the frontend-editing button of joomla. Best, Benjamin

47 Posts
KKAAZZOO
6 months ago
1
Level 5

I will assume that you have overridden the output template? In this case, the appearance of a problem with editing is natural. The correct way is to create a separate edit button and place it in the material output form.

18 Posts
cassirer
6 months ago
0
Level 6

nope, totally naked protostar. Went back to seb 3.20.2 and J! 3.9.25 and it's working. But this seems not to be an solution

16 Posts
SalahJS
6 months ago
0
Level 1

same problem

179 Posts
Pathos
5 months ago
0
Level 1

We have the same problem. Has anybody found a reason or better a solution or hint to where the problem might be?

Regards,

Joris

203 Posts
louispapera
5 months ago
0
Level 1

I have the same problems, version 3.21.5 and joomla 3.10.3, a form that previously work well, now do not work more. Do not save more data. 

Help Help Help..... regards, Louis

1 Post
Salah
4 months ago
2
Level 1

I managed to solve this type of problem:

The first step is to install a new version of Joomla with a new database nameThen install the extentions and templates used in the old site like (seblod ect ...)

Once everything is installed, change the name of the database in the configuration file by adding the name of the old site and do not forget the database prifx

Have a nice day

203 Posts
louispapera
4 months ago
1
Level 2

Thanks for you reply Salah, I am hoping for an intervention by a seblod administrator as I believe there has been some more serious problem they are trying to solve. 

16 Posts
SalahJS
4 months ago
0
Level 3

yes just a troubleshooting solution

126 Posts
Cappu
3 months ago
0
Level 1

Dear Seblod team, this seems to be a serious problem. 

Could it be that you changed the JavaScript function names?

Without beeing an expert on this, just noticed that the JavaScript function called by the button won't exist in the cck.core-3.18.2.min.js.

Screenshots ...

... the onClick JavaScript function call on Buttons:
https://monosnap.com/file/opMXalKjl5geuoAvWJcE2Q2JIElbG1

... inside the JavaScript file:
https://monosnap.com/file/1hozZeW4oK0bNU3CXLGKw8rPKitfyD

Thanks for checking this, your help and your time.

3 months ago
1
Level 1

Hi All,

After a few tests, this issue is confirmed for those using the edit button of Joomla! and only using this native Joomla! button/link.

We advise to use a SEBLOD edit link (which we have been using for years instead of the native one).

  1. Apply a SEBLOD Form Link on an Icon or FreeText field within the Content/Intro/List view.
  2. Go to SEBLOD > Options > Site, Hide Edit Icon = Yes, in order to hide the native one

We'll have a look if it's possible to implement a quick fix before publishing the next release.

Saba

16 Posts
SalahJS
3 months ago
0
Level 2

I applied the modifications you mentioned but the problem still exists.

126 Posts
Cappu
3 months ago
0
Level 1

Hi Saba, thanks very much for helping us! The workaround you mentioned, accessing the frontend forms through SEBLOD Form Link in Seblod List views (hence, not directly through the edit button on Joomla pages) works in my clients Joomla 3.10.5 setup. :-)

16 Posts
SalahJS
1 month ago
0
Level 1

Hello, in the end I have fixed soft comes from the save article error,Well the error is because of the SEO Settings you have to set Search Engine Friendly URLs to yes in the Site Settings part.

1 month ago
1
Level 1

Hi Cappu, SalahJS,

Thanks both for your feedbacks.

Saba

16 Posts
SalahJS
1 month ago
0
Level 2

it's the strength of teamwork

Get a Book for SEBLOD