83 Posts
CAF St Brieuc
3 years ago
6
Topic

Hello

After adding 2 sites, I am disconnected and unable to reconnect to Administration or Frontend. 

No more users can connect.

I had to restore the database. 

I make a second attempt and again, disconnect and can not reconnect. 

Message: "You can not access the administration of this site". 

Restoration database again.

Configuration:
- Php 7.2 / Joomla 3.8.10 / Seblod 3.16.3
- 52 different sites
- 2730 users
- 130 categories

An idea about the problem?

Best regards

G.bob

Get a VIP membership
83 Posts
CAF St Brieuc
3 years ago
5
Level 1

hello

I restored on another base, I updated to joomla 3.8.11 and I redid the site addition the first it goes well and when adding the second, always the same problem, disconnection and impossible to reconnect ...

Best regard

4229 Posts
Kadministrator
3 years ago
4
Level 2

Hi,

which option did you choose for permisisons - owned or inherited? Also, did you follow https://www.seblod.com/resources/manuals/advanced/setting-up-multi-sites

83 Posts
CAF St Brieuc
3 years ago
3
Level 3

Hi Klas,

I already have 52 asset sites, they have their own rights. 
When I add the 53rd all goes well as usual.
It is when I add the 54th that I am disconnected and that I can not reconnect.
I have made a backup of the DB before and after and I will look at the differences there may be.

best regards

83 Posts
CAF St Brieuc
3 years ago
2
Level 4

hi,

After reviewing the tables I can not find anything special that could indicate an error. 

I made another attempt, restore, creation 53th site (ok), 54th site: disconnected again.

Best regards

4229 Posts
Kadministrator
3 years ago
1
Level 5

you are probably hitting some sort of databse limit, multisites was most likely meant for few sites not 54 :)

83 Posts
CAF St Brieuc
3 years ago
0
Level 6

Hi Klass

I found my problem.

The rules field of the table #_assets is a varchar (5120) and this one with the addition of my 54th site I arrived at 5160 characters ...

This is the first line of the assets table which contains: id = 1, parent_id = 0, lft = 0, name = root.1

I passed the size of the field to varchar (8000) and now it's OK.

Is it possible to ask the project joomla to increase the size of this field natively ?

Do you think this can lead to other problems? Updated joomla? updated seblod?

Best regards

Get a Book for SEBLOD