WeStandWithUkraine

105 Posts
nycxav
8 years ago
Topic
Hi, 

I am working on a subscription base site where users can create Seblod content (article) that is published under categories that are restricted to subscribers. I use Akeeba subscriptions for that and I have set up various access levels for the subscriptions.

Everything works except one thing: I want to allow the author of an article to view (and edit) it even though they might not be subscribed to the category the content is published in. In short I would need the "View Own" equivalent to the already existing "Edit Own". Right now after a user has saved their articles if they are not subscribed, they can't see their articles anymore. 

Has anyone ever come across that requirement? Any existing Joomla plugin allowing for this?

Thanks. 
Xav. 
Get a Book for SEBLOD
684 Posts
rpoy
8 years ago
3
Level 1
Hi Xav,

This is probably more of an Akeeba type of question. Why can't the authors have the same access level as the subscriptions?

As far as retrieving their articles, a search type on articles, with the users name would work - but obviously they would need to have access to that level.

regards,

Randy
105 Posts
nycxav
8 years ago
2
Level 2
Hi Randy, 

All Akeeba subscriptions does is automatically assign users to Joomla user groups and remove them when their subscriptions expire. And it does the job well integrating perfectly with Joomla ACL.

The business model of the site is to sell subscriptions to employers who are looking for highly specialized freelancers. The employers are paying a fee.
The authors, the freelancers don't pay to advertise their CV but they must be able to see theirs and modify it. 

I created a series of Access rights for subscribers, linked to user groups and Akeeba adds subscribers to those groups. If I give the author the right to see the subscriber group essentially I give them the right to see everybody's CV for free. If I don't they can't even see their own CV after they have published it. Hence my problem.

Regards.
Xav.
36 Posts
JJL
8 years ago
1
Level 3
Hello,
I have the same problem, and I'm not using akeeba.
Not solved yet, I'm working on it.
By
105 Posts
nycxav
8 years ago
0
Level 4
Hi,

It's not dependent on Akeeba as much as on the Joomla ACL actually. Ackeeba is just a tool to assign the rights automatically.
Please let me know if you find a solution. I'll do the same.

Thanks.
Xav.
4229 Posts
Kadministrator
8 years ago
10
Level 1
Hi,

  • you need to create new search&list type, e.g. "Users Articles", based on your content type and using Table layout
  • Add "Article created by" field to search column and set its Live value (button nb. 2 on the right side) to User
  • Add Article title field to List column and set its Link (button nb. 2 on the right side) to Form
  • Add Menu, e.g. My articles with appropriate access level, e.g. Registered so that suers have to login before they can see it.

This will create a list of users articles with titles linked to edit form. If there is only on article you can also set Auto redirect to Form in Configuration tab of search type, to automatically redirect user to form view.
105 Posts
nycxav
8 years ago
4
Level 2
Hi Klas,

Thanks for your reply, but this doesn't solve the problem.

If I create a list filtered by "created by" but the author doesn't belong to the one group with access to the article they just authored they still won't see it.

If I assign them to the group with rights then I cannot rely on Joomla ACL and I need to check every single link or menu on my site to make sure I set up restrictions and filters everywhere. This is what I would prefer to avoid because even if there are no links to a specific articles, users could "guess" the URLs by incrementing the ids for instance and would still have access to content they are not supposed to see based on their level of subscriptions.

I hope this clarifies what the issue is.

Thanks.
Xav.
4229 Posts
Kadministrator
8 years ago
3
Level 3
Hi,

in my test behaviour was different, without created by filter I got all items titles as text on the list even if user did not have view level access to those articles, but only users one was linked to edit form.  I think key part here is to create link to edit form (not to content as is the case with normal list/blogs)
105 Posts
nycxav
8 years ago
2
Level 4
Hi Klas,

I tried again with a new user just to be 100% sure and my behavior is different and I think the part you are missing is that the article that a user creates is automatically assigned to an ACL group that the user, author of the article, is NOT allowed to see.

Authors only belong to "Registered" but the content they create can only be seen with a custom "Subscriber" level.  In my setup, no matter how the list is created, the registered users never see even the title to their content, let alone any link to view or form. It's as if the piece of content did not exist. And this is the expected behavior in my opinion given the way the ACL work in Joomla.

Regards.
Xav.
4229 Posts
Kadministrator
8 years ago
1
Level 5
From your decription I would say problem is in "registered users" - using default joomla acl gropups you need to assign those users at least Author usergroup that has Edit.own and Create set to allowed, ofcourse you can chage existing groups permissions too.
4229 Posts
Kadministrator
8 years ago
0
Level 6
Also check your search type Acess level (shows if you click on orange arrow)
4 Posts
iamauserher
7 years ago
4
Level 2

Hello. 

I've tried your solution, and made my own list under "List & Search types".

And added "Article created by" search, under "Search form".

And I added "Article Title" under "List", however I cant make it into a link to the edit form.

How do I do that?

--iamauserher

684 Posts
rpoy
7 years ago
3
Level 3

HI iamauserher,

On the Title in the List, select option #2 (Link & Typography).  Under the Link, you can select Form and then define which Content Type you want opened.

regards,

Randy

4 Posts
iamauserher
7 years ago
2
Level 4

Hello Randy.

I tried to do what you suggested, but I am unable to do so. Am I looking in the wrong place? See link for where im looking

http://imgur.com/JPuO3Fe

684 Posts
rpoy
7 years ago
1
Level 5

Hi iamauserher,

Yes you are looking in the wrong place!  You are changing the Field Type - which could be a bad thing for all of your articles.  Article Title type should be text. 

Under the Search and List Type:

Depending on your Search view you are using (LIST or ITEM) - Then select Option #2 on the right side of the Field Construction.

For the Link Type, you can then Select Form.  In my example here, I am using the user position, but you set it up for title.

Hope that helps,

Randy

4 Posts
iamauserher
7 years ago
0
Level 6

Hi Randy.

I wanna thank you for your help. My system works now.

4229 Posts
Kadministrator
8 years ago
0
Level 1
I apologize, I rechecked and while my 2 last posts are true, they don't solve your problem - I was testing with Special view permission and just found it has Author gruoup included, if I remove it list shows nothing.
4229 Posts
Kadministrator
8 years ago
1
Level 1
Ok, I think I found a solution - you need to add Article Access field to your search type and set its live value column (button 2) to your subscription group id. If you have multiple groups in view access level set on the item, you can list them comma separated, then you also need to change Match (button 3) to "Any words exact".

This will override default access check.
105 Posts
nycxav
8 years ago
0
Level 2
Hi Klas,
It works perfectly, thanks for the solution.
Xav.
Get a Book for SEBLOD