WeStandWithUkraine

10 Posts
semi-k
9 years ago
3
Topic

HI,

I discover this morning  that one of (maybe all?) search forms don't show all good results.

I've activated the debug mode. It gave me this request :

SELECT t0.id as pid, t0.pk as pk, t0.pkb as pkb,t0.cck as cck, t0.storage_location as loc,tt.id AS type_id, tt.alias AS type_alias FROM `#__cck_core` AS t0 LEFT JOIN `#__content` AS t1 ON t1.id = t0.pk LEFT JOIN `#__cck_core_types` AS tt ON tt.name = t0.cck WHERE t1.state = 1 AND t1.access IN (1,1) AND ( t1.publish_up = '0000-00-00 00:00:00' OR t1.publish_up <= '2013-08-29 10:05:40' ) AND ( t1.publish_down = '0000-00-00 00:00:00' OR t1.publish_down >= '2013-08-29 10:05:40' ) AND t0.storage_location = "joomla_article" AND t1.introtext REGEXP "(::a_la_une::).*1.*(::/a_la_une::)" GROUP BY t0.pk ORDER BY t1.created DESC

and 3 results O_o

When I put this request directly in PhpMyAdmin, it give me 8 results (good results).

In the search form configuration, I put "limit" to 300 and "Pagination" to "all"...

Please, any help welcome !

Thanks

Jerome


Get a VIP membership
9 years ago
1
Level 1

Hi Jerome,

Don't put a limit and check the results.

The limit is used to say "in how many record in the table SEBLOD must search", if you search in only 300 records when there is more records you will have certainly bad results. This option is to allow some SQL optimization. When you know the max number of records in a table the query is faster with a limit.

Regards.

10 Posts
semi-k
9 years ago
0
Level 2

Thanks for reply, unfortunately even I put 0 in the "limit" field, SEBLOD get only 3 items to the template, but it should get 8... :-/

10 Posts
semi-k
9 years ago
0
Level 1

OK sorry, I found the problem : the max number result was fixed in the module configuration too... and the limit was fixed on 3.

Get a Book for SEBLOD