449 Posts
gebeer
9 years ago
Topic

Hello,

thank you for the free importer component.

Today I wanted to use it for the first time to import some country data. But my title and alias field don't get populated. Instead I have the datetime of the import as countryname and datetimewith appended number as alias.

My content type country consists of only 4 fields:

countryiso: Storage standard Article countryiso; stored in table #__cck_store_form_country field countryiso

countryname: Storage standard Article title, stored in table #__content field title

art_alias: Storage standard Article alias, stored in table #__content field alias

cat_id: Storage Standard Article catid, stored in table #__content field catid

My CSV file reads like:

countryiso,countryname,art_alias,art_catid
AT,Austria,austria,50
BE,Belgium,belgium,50
...

I have only 30 rows in my CSV

I'm using SEBLOD 3.5 on J!2.5.28 and Importer 1.3.3.

My settings for import are:

Article Standard

Content type: Country

Category: my country category

Maybe the importer cannot handle the import because not all data is sitting in the same table?

Also when I don't set the category on import, the articles are not created in category with id 50 but in Uncategorised.

Please help. Thank you.

Get a Book for SEBLOD
449 Posts
gebeer
9 years ago
0
Level 1

SOLVED

After re-reading the manual for importer, I changed my CSV to read:

countryiso,title,alias,catid,state
AT,Austria,austria,50

...

Now everytrhing is working fine.

9 years ago
0
Level 1

Thanks Gebeer!

Get a VIP membership