449 Posts
gebeer
10 years ago
Topic
Hello all,

I'm using a list module to list articles and link from that list to the single article view.

The links that are created by the list module look like this:
http://www.my-domain.com/coaching/zertifizierung-lizenz/adressverzeichnis.html?id=201:max-huber

I actually want them to look like this:
http://www.my-domain.com/coaching/zertifizierung-lizenz/adressverzeichnis/max-huber.html

Is there a way that we can achieve this in SEBLOD?
Or doI need a SEF component?

Any suggestions on how to do this would be much appreciated. Thank you.
Get a VIP membership
449 Posts
gebeer
10 years ago
0
Level 1
OK, I found out how to make the URLs of lists look nicer to SEs.

In the configuration tab there is a option for SEF URLs. I just didn't see that before I posted my question.

So if you choose /alias or /parent alias there, you should see a SEF friendly URL.
9 years ago
1
Level 1
Hello, gebeer
I have the same problem, but the solution doesn't work. I don't want to write custom link for this...
449 Posts
gebeer
9 years ago
0
Level 2
Hello ComeOn,

Have you enebled SEF URLs and URL rewrite in general Joomla configuration?
9 years ago
10
Level 1
Yes, I have /alias(safe) settings for all articles. I changed this setting in global configuration of SEBLOD and in Configuration tab in my search and in Link(view) window for concret field.
449 Posts
gebeer
9 years ago
9
Level 2
I was talking about Joomla System->Global Configuration->SEO Settings
9 years ago
8
Level 3
Yes, of course. http://SSMaker.ru/8b70a72b/ - it is with russian, but I think, you'll understand
449 Posts
gebeer
9 years ago
7
Level 4
Sorry, then I have no idea.

Have you tried other settings parent/alias etc?
9 years ago
6
Level 5
Yes. When I have chosen parent/alias, parent_id=XX was added to link :)
21 Posts
abc123
9 years ago
5
Level 6
I also had a similar problem i had a module on home that showed images that led to articles that had problems with SEF URL.
I fixed it by also adding an menu to my images field.
"List & Search Type">"Item" my_field > 2(Link + Typography) > "View" "+" "Menu Item" choose an menu.
I had to do this because my module showed up in the target article when i opened it with my module.
This fixed both module shows in target link and my SEF problem.
9 years ago
4
Level 7

Hi

I have a similar probleme here:

I have a menu item (mymenu) pointing to one content (first-article) and then, on this content page, a seblod list module displaying related contents with a SEE(+) link on them.

The first content is properly accessed through the /mymenu/first-article sef url.

BUT the sef links on the related contents are /mymenu/first-article?id=xx:content-alias instead of /mymenu/content-alias.

I activated both joomla sef options and seblod sef option is set to /alias. in the seblod list config the sef parameter is set to inherited, as in the SEE(+) plugin.

If I set seblod SEF options to parent/alias the related urls are /mymenu/first-article/xx:content-alias which is NOT what I want (/mymenu/content-alias)

thanks for your tips

21 Posts
abc123
9 years ago
2
Level 8

Sometimes adding "SEF Content Type(s)" to your search helps you do that and/or the tip i posted in my previous reply in this thread.

9 years ago
1
Level 9

Hi

I don't understand what we should write in this "SEF Content Type(s)" field

thanks

cyril

21 Posts
abc123
9 years ago
0
Level 10

If you go to "Form & Content Type Manager" and you will see your content types, first you will see the name (it's also a link to the content type) and under it you will see a smaller name and that's the one you use.

21 Posts
abc123
9 years ago
0
Level 8

My colleague had a similar problem with SEF today and i found out the the problem was that he had chosen Object "Free" instead of Article.

List & Search > Your_list_and_search_type > yellow arrow > Object > Article

Get a VIP membership