This site uses cookies and similar technologies.

If you don't change browser settings, you agree to it.

I understand
30 Posts
tiagovareta
3 months ago
Topic

Hi,

I'm translating the Seblod fields using JText, but I'm having some problems: http://prntscr.com/klom0j
-I think not to translate the fields in "Override", in the image the Green and Yellow Fields does not have Override and does the translation, the red fields are part of the override and are not translated. In Joomla Languages / Overlays I called right: http://prntscr.com/klompj

- Define variables with accents, and when I go in Joomla to Languages / Overlays does not assume the accents (fields to yellow): http://prntscr.com/klon0e

How can I solve these situations ???

Get a Book for SEBLOD
4026 Posts
Klasadministrator
3 months ago
1
Level 1
  • How do you call your fields in the override? $cck->renderField should give you translated labels
  • For accents problem: instead of entering real text as option, enter language key without COM_CCK, e.g. SELECIONE_A_REGIO
30 Posts
tiagovareta
3 months ago
0
Level 2

Hi Klas,

Many thanks for the reply!

  • How do you call your fields in the override? $cck->renderField should give you translated labels

- In override file: http://prntscr.com/klz9er
- In Joomla Override Translation: http://prntscr.com/klz9zh
- Result in FrontEnd: http://prntscr.com/klzaca


  • For accents problem: instead of entering real text as option, enter language key without COM_CCK, e.g. SELECIONE_A_REGIO

- Variable in FrontEnd: http://prntscr.com/klzb30
- In Joomla Override Translation: http://prntscr.com/klzbmt (I tried only with the variable: SELECT_A_REGIO and with both. If I put the name of the FrontEnd variable exactly, saving it removes the characters with accents.)
- Result in FrontEnd: http://prntscr.com/klzctv

I tried to use both of the tips that you indicated, but so far they have not worked ... Is there anything else I can do?

4026 Posts
Klasadministrator
3 months ago
1
Level 1

For first problem: it looks that language file is not loaded for some reason, is this list or item view or even list in module? Yu should enable joomla language debugging to see which language files are loaded and which strings are missing.

For the accent problem - you need to enter SELECIONE_A_REGI as Select simple (or dynamic, whatever you have) text option (in the field configuration, not in the language file), Don't use accented characters for labels, add accents only in language file.

30 Posts
tiagovareta
3 months ago
0
Level 2

Hi Klas,

Thanks for the answer!

The situation of the accents, I already figured out how to solve. It works fine: http://prntscr.com/km2w4q

The situation of overridden fields, I activated Debug Language. According to Joomla:

●Joomla CMS●(text surrounded by bullets) indicates that a match has been found in the language definition file and the string has been translated.
??Joomla CMS??(text surrounded by pairs of question marks) indicates that the string is translatable but no match was found in the language definition file.

In my case the fields in Override appear with "??": http://prntscr.com/km2xqk

Another strange thing is that in the fields where I managed to override the translation the variable appears like this: http://prntscr.com/km2zrb

In fields that I am not able to override, the variable appears "split in two": http://prntscr.com/km30bs

- How can I know which translation files are being uploaded?

- What is the reason for the variable being "split in two"? Is there a way to put it all together?

30 Posts
tiagovareta
3 months ago
2
Level 1

I think I have already found the reason why, not to assume the language override, in the fields.

I think the source of the error, was to have in the "label" option of Seblod, have the bold tags: http://prntscr.com/km3kxj

I took out the bold tags and the ":", and put this information in the override, and it worked ...

4026 Posts
Klasadministrator
3 months ago
1
Level 2

Actually seems like the same problem as with accents - language keys should be plain ASCII text as Joomla expects that when doing translations.

30 Posts
tiagovareta
3 months ago
0
Level 3

Hi Klas,

Thanks a lot for the help!
Your tips, suggestions, have been very important. Thank you!

Get a Book for SEBLOD